ubuntu 10.04 下编译安装最新版 VIM7.3 支持GUI(gvim)编译

ubuntu 10.04  下编译安装最新版 VIM7.3 支持GUI(gvim)编译

1下载 vim 源码,hg clone https://vim.googlecode.com/hg/ vim

2. 进入源码目录cd vim/src
安装gvim所需要的包。
sudo apt-get install libncurses5-dev libgnome2-dev libgnomeui-dev \
libgtk2.0-dev libatk1.0-dev libbonoboui2-dev libcairo2-dev libx11-dev libxpm-dev libxt-dev

上面的包可以有选择的安装,如果用gnome,那么只装部分就可以了

编译配置
./configure –prefix=/usr/local –with-features=huge –enable-pythoninterp –enable-gui=gnome2 –enable-cscope –enable-fontset –enable-perlinterp –enable-python3interp –enable-tclinterp –enable-multibyte

编译

make
安装
sudo make install

ubuntu 10.04 下编译安装最新版 VIM7.3 支持GUI(gvim)编译
标签:         

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*